PDA

View Full Version : Help! What is the best move?



Phatality
07-22-2012, 04:26 PM
So I have this gaming computer that I've had since about 2008 give or take and it's pretty much dead now.


It powers on, all fans run but the screen remains blank and there are no beeps, nothing. Occasionally it will start up only to the starting text screen informing me my overclock had failed and will load default settings, however I've never overclocked anything in my machine.
There is no power to the USB ports or any other Peipherals except maybe for a split second.


Before it completely chitted out I would get artifacts when playing games and eventually watching movies or anything else animated etc etc.
There were some days when it ran flawlessly.

So I thought this was my graphics card but why isn't it making it to startup?

Key specs:
MOBO: MSI P7N SLI-FI LGA775 nForce750i
Graphics Card:9800GTX

Should I replace both? Is there a way to isolate the problem?
Would it be more cost effecient just to buy a new CPU,MOBO and Graphics Card and keep my PSU, Drives and everything else?

Looking for low budget fix.

Videophile
07-24-2012, 08:16 AM
Does your motherboard have onboard video? You'd probably need a VGA cable but if you remove the video card from the system and try to boot using the video on your motherboard and it works, you probably have a bad video card. It could also be memory. If you can get some inexpensive memory and swap it with your current RAM, that will get you one step closer. If neither of those work, you can try removing peripherals one at a time and try to boot after each part is removed. Hard drive, dvd drive, etc. Those are unlikely but at least you can be certain it's not one of those devices causing problems. Lastly, if all else fails then you're probably looking at a motherboard or cpu issue.

Nara62629
07-24-2012, 10:24 AM
i would remove the gpu first and see if its that.

Phatality
07-25-2012, 12:17 AM
No onboard graphics.

KRANE
07-25-2012, 12:36 AM
So I have this gaming computer that I've had since about 2008 give or take and it's pretty much dead now.


It powers on, all fans run but the screen remains blank and there are no beeps, nothing. Occasionally it will start up only to the starting text screen informing me my overclock had failed and will load default settings, however I've never overclocked anything in my machine.
There is no power to the USB ports or any other Peipherals except maybe for a split second.


Before it completely chitted out I would get artifacts when playing games and eventually watching movies or anything else animated etc etc.
There were some days when it ran flawlessly.

So I thought this was my graphics card but why isn't it making it to startup?

Key specs:
MOBO: MSI P7N SLI-FI LGA775 nForce750i
Graphics Card:9800GTX

Should I replace both? Is there a way to isolate the problem?
Would it be more cost effecient just to buy a new CPU,MOBO and Graphics Card and keep my PSU, Drives and everything else?

Looking for low budget fix.It sounds like you have a computer that has been pretty badly abused. Mine is from that year and still work (and nearly looks) like new.

At this point I don't think it will be worth it to try and fix anything. Its just too old; and you will never recoup the investment. Not to mention 4 year is a useful life. Get a new one and try and take care of it better.